Problema serio con la gestione pacchetti

Richieste varie sui NAS Server Synology
Rispondi
ginopilotino
Utente
Utente
Messaggi: 60
Iscritto il: venerdì 29 gennaio 2010, 22:31

Problema serio con la gestione pacchetti

Messaggio da ginopilotino » venerdì 13 luglio 2018, 18:58

Per un problema con due dischi (uno errori smart e bloccato da DS e l'altro prima bloccato da DS e poi sparito completamente) ho spento ed inserito un terzo disco "buono". Gia' prima di configurarlo mi dava errori su un po' tutti i pacchetti, ma ho ignorato e configurato il nuovo volume. Poi ho spento, tolto i vecchi e riacceso col solo nuovo.

Non ricordo se la riparazione dei pacchetti l'ho fatta prima o dopo aver tolto i dischi guasti, sta di fatto che era rimasto solo "MODS_PackageManager" in errore, un pacchetto di terze parti che non si riusciva a riparare. Inoltre risultava e risulta impossibile rimuovere o aggiornare qualsiasi pacchetto.
Sono andato in /var/packages/ ed ho rimosso la dir di MODS_PackageManager, quindi e' sparito dal centro pacchetti. Ma continua a non potersi installare o rimuovere nulla. Ricevo sempre, dopo un sacco di tempo, un errore:

"E' stato configurato, installato o ripristinato un altro pacchetto. Riprovare in seguito"

Ho anche provato a rinominare la dir di filestation e ad installarlo manualmente, stesso errore.
Penso ci sia qualcosa che punta alle dir dei precedenti volumi. Mi ritrovo infatti un volume1 e volume2 praticamente vuoti, con solo la dir @eaDir in entrambe. Mentre sul volume3, che e' quello dell'unico disco installato, ho tutto il resto.
Questo mi da df:
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 2451064 831016 1517648 36% /
none 242740 0 242740 0% /dev
/tmp 246836 668 246168 1% /tmp
/run 246836 2152 244684 1% /run
/dev/shm 246836 4 246832 1% /dev/shm
/dev/vg1000/lv 3840953648 780225288 3060625960 21% /volume3

Ora vorrei capire che diavolo succede. Il nas funziona perfettamente, a parte la gestione dei pacchetti. Le app funzionano ed anche tutte le impostazioni, mi pare. Quindi e' un problema del gestore pacchetti.
Potrei rasare tutto e ripartire da zero, lo uso solo come target di hyperbackup, ma vorrei capire come sistemare le cose.
  • UPS: APC CS650
  • GTW: Fastgate + vari; ISP: Fastweb IP:Public
  • SWC: Vari
  • NAS: 1515+ DSM6 Ram 16GB Storage SHR(2x4TB RED + 1x4TB RED Pro + 2x4TB Seagate VX) - 918+ DMS6 RAM 4GB Storage SHR btrfs (3x3TB SkyHawk)
  • CLI: Windows 7/10
  • WD Live HD - Vodafone TV Solution - Amazon Fire Tv Stick
  • EXP: E4 - NET10 PC:W10,M7,L8

Rispondi

Torna a “DOMANDE GENERICHE”