Volume danneggiato

Gestore archiviazione, problemi HDD e configurazioni RAID/iSCSI
Rispondi
xspeed
Utente
Utente
Messaggi: 5
Iscritto il: venerdì 17 novembre 2017, 13:11

Volume danneggiato

Messaggio da xspeed » domenica 3 febbraio 2019, 12:25

Ciao a tutti,

vi scrivo dopo l'ennesimo problema che sto riscontrando con il mio NAS DS416play (o meglio con i miei dischi WD RED).
Dal 2017 ad oggi ho dovuto sostituire un numero ormai imprecisato di HD WD RED a causa di settori danneggiati (per fortuna in garanzia) - a sentire l'assistenza WD il mio è un caso più unico che raro, dato da una particolare sfortuna. Mah...

Pensavo di essere uscito da questa esperienza frustrante: da diversi mesi stava filando tutto liscio. Nel frattempo ho aggiunto un quarto disco Seagate Ironwolf (mai più WD per quanto mi riguarda).

Ma... purtroppo questa mattina mi sono accorto che il Volume è in stato Danneggiato.

La cosa strana rispetto alle altre volte è che nelle proprietà del disco2 che risulta danneggiato, tutto sembra regolare, non ci sono settori danneggiati. Risulta però "non inizializzato". Ho effettuato un test rapido SMART, conclusosi regolarmente senza segnalare errori.

Verificando le notifiche di sistema risultano segnalazioni di settori danneggiati nel disco2 risalenti a qualche mese fa, come può essere che nelle proprietà disco il contatore dei settori danneggiati sia a zero?? Tra l'altro ho notato che anche per il disco1 risultano errori nel log, ma non nelle proprietà disco!

Vi allego qualche screenshot della mia situazione attuale, voi cosa mi consigliate di fare? E' davvero un problema del disco/dischi?

Grazie mille a tutti
Alessandro
01.png
01.png (130.18 KiB) Visto 196 volte
02.png
02.png (130.57 KiB) Visto 196 volte
03.png
03.png (159.92 KiB) Visto 196 volte
04.png
04.png (149.35 KiB) Visto 196 volte
05.png
05.png (176.74 KiB) Visto 196 volte
  • UPS: APC Back-UPS BX - BX700UI
  • SWC: TP-Link TL-SG1024
  • NAS: DS416play DSM 6.2.1-23824 Update 4
  • HDD: 3 x WD RED 4TB + 1 x Seagate Ironwolf 4TB btrfs Raid 5
  • CLI: MacBook Pro 2012 - Mojave

Avatar utente
Giox040
Utente
Utente
Messaggi: 55
Iscritto il: martedì 20 ottobre 2015, 10:28

Re: Volume danneggiato

Messaggio da Giox040 » mercoledì 6 febbraio 2019, 15:31

Anch'io recentemente ho ricevuto degli avvisi del genere, la prima volta sul disco 1, dopo circa un mese sul disco 2 e dopo un altro mese circa di nuovo sul disco1.
Per 2 volte il nas mi ha segnalato che dopo diversi tentativi il disco ha ripreso a funzionare regolarmente, una volta ho dovuto far riparare il pool (dopo aver smontato il disco e testato su un pc con Ubuntu (non avendo un desktop windows con sata) senza incontrare errori).

Rifacendo poi lo smart test sul nas, anche approfondito, non evidenzia piu' alcun problema.

Per il momento sto andando avanti senza sostituire i dischi, pero' faccio sempre il backup su dei dischi esterni.

C'e' da dire che il mio nas da sempre vibra, ho messo degli spessorini sulle slitte dei dischi e sui piedini, e' migliorato abbastanza ma talvolta va ancora in risonanza ed inizia a vibrare. Forse cio' comporta instabilità nelle connessioni sata.
Io uso advance power manager ed ogni giorno faccio accendere il nas a tardo pomeriggio e spegnerlo dopo le 22.00 ma questo non dovrebbe essere fonte di stress, milioni di pc con dischi di tutti i tipi vengono accesi e spenti ogni giorno per molti anni senza problemi agli HD.

Ho cercato in rete e mi sembra che il problema sia molto diffuso, ho l'impressione che Synology abbia poca simpatia per i dischi WD RED.

Per quanto riguarda i settori danneggiati rilevati in precedenza e non piu' visualizzati nelle proprieta' del disco, mi sembra ma chiedo conferma a chi ne sa di piu', che sia dovuto al fatto che il disco usi dei settori di riserva al posto di quelli danneggiati e quindi successivamente non vengano piu' visti come danneggiati dal nas.
  • UPS: No
  • Gateway: TP-Link TD-W8970v1 con LEDE(OpenWRT) - ISP: ADSL Infostrada (10M/1M) - IP:Public
  • Switch: D-Link DGS-108 | Netgear FS605
  • NAS: Synology DS214+ - DSM 6.0 - 1Gb - R1(2xWDRed3TB) - 1xWDRed3TB su eSata - 1x500Mb su USB - LAN:1
  • Client: Ubuntu su P4 | Win10-32 su AMD Athlon 64 x2 6000+ | Win10-64 su Notebook2,6 GHz Intel Core i5-3230M
  • IP-Cam: Foscam FI9818w v2
  • Android: Asus Zenfone2 ZE551ML

xspeed
Utente
Utente
Messaggi: 5
Iscritto il: venerdì 17 novembre 2017, 13:11

Re: Volume danneggiato

Messaggio da xspeed » domenica 10 febbraio 2019, 20:04

Grazie per le indicazioni!
Ho effettuato il backup dei dati e lanciata la riparazione dello Storage pool senza sostituire il disco.
Speriamo bene...

In ogni caso penso acquisterò dei Seagate Ironwolf per sostituire progressivamente i WD RED, non voglio rimanere con l'ansia di perdere tutto da un momento all'altro! :(
  • UPS: APC Back-UPS BX - BX700UI
  • SWC: TP-Link TL-SG1024
  • NAS: DS416play DSM 6.2.1-23824 Update 4
  • HDD: 3 x WD RED 4TB + 1 x Seagate Ironwolf 4TB btrfs Raid 5
  • CLI: MacBook Pro 2012 - Mojave

Rispondi

Torna a “Storage (HDD, RAID, SHR, iSCSI, SSD e Cache)”