Ds Video e connessione tramite HTTPS

Usare il NAS per gestire le librerie dei contenuti video, la Video Station
Rispondi
Mcmar_
Utente
Utente
Messaggi: 43
Iscritto il: lunedì 21 novembre 2016, 22:58

Ds Video e connessione tramite HTTPS

Messaggio da Mcmar_ » sabato 18 novembre 2017, 22:41

Salve.
Ho un problema nell'usare Ds Video da fuori per collegarmi al Nas di casa usando HTTPS.
Cioè se abilito (con spunta su DS Video) la connessione con HTTPS, poi non si collega e appare il seguente errore :
"Il certificato SSL della DiskStation non è fidato. Ciò può significare che è un certificato autofirmato o qualcuno può cercare di intercettare la tua connessione".
Senza la spunta HTTPS invece mi collego e sfoglio normalmente la libreria multimediale.
Ho provato a cercare qualche soluzione sulla rete, ma non ne sono venuto a capo.
Grazie
  • UPS: APC Back-UPS 700VA (BX700UI)
  • GTW: Technicolor TG1100 ISP: Fastweb Fibra FTTH 100Mbps/50Mbps IP:Public
  • SWC: Tp-Link TL-SG1005D 1000Mbps
  • NAS: Synology DS416; DSM 6.0.2-8451 Update 7; 1GB MB Ram; SHR1(WD Red 4TB + 2WD Red 8TB); LAN:1;
  • CLI: Pc Win7;
  • ALTRO: Ipad; Ipad mini2; Tablet Asus Android; Galaxy S5;
  • EXP: E4 - NET5 PC:W6,M0,L0

Avatar utente
burghy86
Moderatore
Moderatore
Messaggi: 8807
Iscritto il: martedì 11 settembre 2012, 18:59

Re: Ds Video e connessione tramite HTTPS

Messaggio da burghy86 » domenica 19 novembre 2017, 0:50

Devi avere un certificato ssl valido che puoi avere gratis con let's encrypt oppure comprare un dominio e un certificato geotrust
ATTENZIONE PRIMA DI POSTARE
Passare dalla sezione presentazioni e leggere il regolamento firma obbligatorio

siamo una community, aiutateci a sentirci parte di qualcosa e non un helpdesk
Non do aiuto in privato ma sul forum a tutti!!
Un grazie ci spinge a lavorare meglio
------------------------------------------------------------
  • UPS: apc
  • GTW: netgear dgn2200 o TP-LINK TD-W8970 ISP: [ADSL] intred(20000/1024/0) IP:[pubblico]
  • SWC: hp gigabit 8 porte with poe
  • NAS: ds213, ds213j,ds210j,ds413j, ds215j, ds415+ dmv dal 5.2 alla 6. qnap ts212p ts22, all hd con wdred da 2/6tb
  • CLI: xpsp3, seven pro 64bit, win 8.1 64bit, mac, win 10
    [altro]
  • 3 smartphone android, un iphone5,lettore bd with allshare samsung, vodafone tv, raspberry p2 e p3

Avatar utente
dMajo
Moderatore
Moderatore
Messaggi: 1682
Iscritto il: sabato 18 agosto 2012, 23:14
Località: FVG - Italia

Re: Ds Video e connessione tramite HTTPS

Messaggio da dMajo » domenica 19 novembre 2017, 4:56

Io uso DSVideo con HTTPS sin dalla notte dei tempi. Prima avevo un certificato autofirmato, ora ne ho uno rilasciato da un'autorità riconosciuta.
In entrambi i casi non ho mai avuto problemi. Per la riproduzione uso generalmente MXPlayer.
Dal 01.01.2015 non rispondo a quesiti tecnici dei non osservanti il regolamento http://www.synologyitalia.com/presentazioni/regolamento-leggere-prima-di-postare-t5062.html

  • UPS: APC SMT2200I+AP9631
  • GTW: Vigor2862Vac(3.8.8.2): Multiwan 2xVDSL(200M/30M,1+8IP)+USB4G :o
  • SWC: DLink DGS1210-28P (PoE+)
    • 4x HP NJ2000G
    • 4x HP NJ220
    • 2x Netgear GS108Tv2
    • 2x VigorAP902
  • NAS: DS1815+: DSM6.1(15152u3),16GB; R1(2x845DCPro),R5(3xWD60EFRX),R0(2xWD60PURX),VB(WD60EFRX);LAN:LAG(1+2),3,4 :D
    • RS3617xs+: DSM6.1(15152u3),8GB; R5(8xWD40FFWX),HS(WD40FFWX); LAN:LAG(1+2+3),4,LAG(5+6)
    • RS2414RP+: DSM5.2(5967u1),4GB; R10(4xWD30EFRX),R5(3xWD30EFRX),HS(WD30EFRX); LAN:LAG(1+2+3),4
  • ALTRO: Denon AVR-4311
    • UE55ES8000Q, UE32ES6800Q, UE22F5410AY
    • Galaxy Note8, A5, TabS3; Nokia N8
  • EXP: E4: NET9 PC:W9,M0,L6

Mcmar_
Utente
Utente
Messaggi: 43
Iscritto il: lunedì 21 novembre 2016, 22:58

Re: Ds Video e connessione tramite HTTPS

Messaggio da Mcmar_ » domenica 4 marzo 2018, 19:15

dMajo ha scritto:Io uso DSVideo con HTTPS sin dalla notte dei tempi. Prima avevo un certificato autofirmato, ora ne ho uno rilasciato da un'autorità riconosciuta.
In entrambi i casi non ho mai avuto problemi. Per la riproduzione uso generalmente MXPlayer.
Riesumo la discussione.
Sul tablet android ho importato il certificato di default della synology (scheda certificati), ma con DS Video non ottengo nessun risutato.
Mi appare sempre quel messaggio di errore e non mi fa collegare.

Nel dettaglio:
- esporto il certificato della synology e mi da 4 file ( cert.pem; privkey.pm; syno-ca-cert.pem; syno-ca-privkey.pem ).
- copiati nel tablet, mi fa installare solo il 1 e il 3.
- in DS Video spunta su https e su impostazioni di accesso verificare il certificato.

Ma nada. Nulla. Sempre errore.

Ma per usare in maniera sicura DS Video sul mio Nas, devo per forza ottenere un certificato da terzi ???
Se cosi fosse non capisco il senso di quello di default che ho trovato, e piu in generale di quelli autocertificati.
  • UPS: APC Back-UPS 700VA (BX700UI)
  • GTW: Technicolor TG1100 ISP: Fastweb Fibra FTTH 100Mbps/50Mbps IP:Public
  • SWC: Tp-Link TL-SG1005D 1000Mbps
  • NAS: Synology DS416; DSM 6.0.2-8451 Update 7; 1GB MB Ram; SHR1(WD Red 4TB + 2WD Red 8TB); LAN:1;
  • CLI: Pc Win7;
  • ALTRO: Ipad; Ipad mini2; Tablet Asus Android; Galaxy S5;
  • EXP: E4 - NET5 PC:W6,M0,L0

Avatar utente
burghy86
Moderatore
Moderatore
Messaggi: 8807
Iscritto il: martedì 11 settembre 2012, 18:59

Re: Ds Video e connessione tramite HTTPS

Messaggio da burghy86 » domenica 4 marzo 2018, 20:48

Perché non crei un certificato pippo.synology.me con lets encrypt? Metti il dominio e la tua mail
ATTENZIONE PRIMA DI POSTARE
Passare dalla sezione presentazioni e leggere il regolamento firma obbligatorio

siamo una community, aiutateci a sentirci parte di qualcosa e non un helpdesk
Non do aiuto in privato ma sul forum a tutti!!
Un grazie ci spinge a lavorare meglio
------------------------------------------------------------
  • UPS: apc
  • GTW: netgear dgn2200 o TP-LINK TD-W8970 ISP: [ADSL] intred(20000/1024/0) IP:[pubblico]
  • SWC: hp gigabit 8 porte with poe
  • NAS: ds213, ds213j,ds210j,ds413j, ds215j, ds415+ dmv dal 5.2 alla 6. qnap ts212p ts22, all hd con wdred da 2/6tb
  • CLI: xpsp3, seven pro 64bit, win 8.1 64bit, mac, win 10
    [altro]
  • 3 smartphone android, un iphone5,lettore bd with allshare samsung, vodafone tv, raspberry p2 e p3

Mcmar_
Utente
Utente
Messaggi: 43
Iscritto il: lunedì 21 novembre 2016, 22:58

Re: Ds Video e connessione tramite HTTPS

Messaggio da Mcmar_ » domenica 4 marzo 2018, 23:45

Ti ringrazio della risposta.
Pero' non capisco una cosa.
Con Ds video per entrare uso il mio indirizzo ip e la porta che ho scelto di aprire, tipo 94.xx.xx.xx:1234.
Ed ovviamente nome e password.
Il dominio che dovrei registrare che attinenza avrebbe con tutto questo ?
Forse è la traduzione certificata del mio indirizzo ip ?
E se cosi fosse, debbo comunicare anche la porta che ho aperto ? Non ci son problemi di sicurezza ?
  • UPS: APC Back-UPS 700VA (BX700UI)
  • GTW: Technicolor TG1100 ISP: Fastweb Fibra FTTH 100Mbps/50Mbps IP:Public
  • SWC: Tp-Link TL-SG1005D 1000Mbps
  • NAS: Synology DS416; DSM 6.0.2-8451 Update 7; 1GB MB Ram; SHR1(WD Red 4TB + 2WD Red 8TB); LAN:1;
  • CLI: Pc Win7;
  • ALTRO: Ipad; Ipad mini2; Tablet Asus Android; Galaxy S5;
  • EXP: E4 - NET5 PC:W6,M0,L0

Avatar utente
burghy86
Moderatore
Moderatore
Messaggi: 8807
Iscritto il: martedì 11 settembre 2012, 18:59

Re: Ds Video e connessione tramite HTTPS

Messaggio da burghy86 » lunedì 5 marzo 2018, 0:42

Da locale non c'è problema se usi un http. È da remoto che è più sicuro un dominio ddns ed ssl o quello che hai che puoi collegarti al nas con videostation ssl
ATTENZIONE PRIMA DI POSTARE
Passare dalla sezione presentazioni e leggere il regolamento firma obbligatorio

siamo una community, aiutateci a sentirci parte di qualcosa e non un helpdesk
Non do aiuto in privato ma sul forum a tutti!!
Un grazie ci spinge a lavorare meglio
------------------------------------------------------------
  • UPS: apc
  • GTW: netgear dgn2200 o TP-LINK TD-W8970 ISP: [ADSL] intred(20000/1024/0) IP:[pubblico]
  • SWC: hp gigabit 8 porte with poe
  • NAS: ds213, ds213j,ds210j,ds413j, ds215j, ds415+ dmv dal 5.2 alla 6. qnap ts212p ts22, all hd con wdred da 2/6tb
  • CLI: xpsp3, seven pro 64bit, win 8.1 64bit, mac, win 10
    [altro]
  • 3 smartphone android, un iphone5,lettore bd with allshare samsung, vodafone tv, raspberry p2 e p3

Mcmar_
Utente
Utente
Messaggi: 43
Iscritto il: lunedì 21 novembre 2016, 22:58

Re: Ds Video e connessione tramite HTTPS

Messaggio da Mcmar_ » lunedì 5 marzo 2018, 1:36

Sto provando a registrarmi, dal Dsm, a lets encrypt.
Ma non me lo fa fare, perche dice di verificare che la diskstation e il router abbiano la porta 80 aperta per la convalida del dominio.

Sul firewall della Dsm è abilitato il servizio di photo station, web station, web mail che apre la porta 80 su http.
Sul router è stata creata una regola personalizzata che apre la porta 80 e la traduce in 80. Sia Tcp che udp.

Ma nulla. Appare quel messaggio e non me lo fa fare.
  • UPS: APC Back-UPS 700VA (BX700UI)
  • GTW: Technicolor TG1100 ISP: Fastweb Fibra FTTH 100Mbps/50Mbps IP:Public
  • SWC: Tp-Link TL-SG1005D 1000Mbps
  • NAS: Synology DS416; DSM 6.0.2-8451 Update 7; 1GB MB Ram; SHR1(WD Red 4TB + 2WD Red 8TB); LAN:1;
  • CLI: Pc Win7;
  • ALTRO: Ipad; Ipad mini2; Tablet Asus Android; Galaxy S5;
  • EXP: E4 - NET5 PC:W6,M0,L0

Mcmar_
Utente
Utente
Messaggi: 43
Iscritto il: lunedì 21 novembre 2016, 22:58

Re: Ds Video e connessione tramite HTTPS

Messaggio da Mcmar_ » lunedì 5 marzo 2018, 1:41

Aggiornamento.
Ora mi dice " L'operazione non è riuscita. Accedere nuovamente al DSM e riprovare".
Sono uscito. Rientrato al Dsm con nome e password, ma mi dice sempre che l'operazione non è riuscita e di riaccedere al Dsm e riprovare.
:shock: :shock: :shock:
  • UPS: APC Back-UPS 700VA (BX700UI)
  • GTW: Technicolor TG1100 ISP: Fastweb Fibra FTTH 100Mbps/50Mbps IP:Public
  • SWC: Tp-Link TL-SG1005D 1000Mbps
  • NAS: Synology DS416; DSM 6.0.2-8451 Update 7; 1GB MB Ram; SHR1(WD Red 4TB + 2WD Red 8TB); LAN:1;
  • CLI: Pc Win7;
  • ALTRO: Ipad; Ipad mini2; Tablet Asus Android; Galaxy S5;
  • EXP: E4 - NET5 PC:W6,M0,L0

Avatar utente
dMajo
Moderatore
Moderatore
Messaggi: 1682
Iscritto il: sabato 18 agosto 2012, 23:14
Località: FVG - Italia

Re: Ds Video e connessione tramite HTTPS

Messaggio da dMajo » lunedì 5 marzo 2018, 15:08

Mcmar_ ha scritto:
dMajo ha scritto:Io uso DSVideo con HTTPS sin dalla notte dei tempi. Prima avevo un certificato autofirmato, ora ne ho uno rilasciato da un'autorità riconosciuta.
In entrambi i casi non ho mai avuto problemi. Per la riproduzione uso generalmente MXPlayer.
Riesumo la discussione.
Sul tablet android ho importato il certificato di default della synology (scheda certificati), ma con DS Video non ottengo nessun risutato.
Mi appare sempre quel messaggio di errore e non mi fa collegare.

Nel dettaglio:
- esporto il certificato della synology e mi da 4 file ( cert.pem; privkey.pm; syno-ca-cert.pem; syno-ca-privkey.pem ).
- copiati nel tablet, mi fa installare solo il 1 e il 3.
- in DS Video spunta su https e su impostazioni di accesso verificare il certificato.

Ma nada. Nulla. Sempre errore.

Ma per usare in maniera sicura DS Video sul mio Nas, devo per forza ottenere un certificato da terzi ???
Se cosi fosse non capisco il senso di quello di default che ho trovato, e piu in generale di quelli autocertificati.
Non serve che tu importi i certificati sui dispositivi ... semmai il solo syno-ca-cert, che è l'autority con la quale è firmato il cert.pem.

Io non ho mai usato quickconnect ne ddns, anche e il secondo è ininfluente rispetto ad un dominio tradizionale che punti un ip statico.
Io non ho mai aperto le porte 5000/5001 (ne sue sostitute) all'esterno.

Per tutte le app ho abilitato, nel portale applicazioni, le porte personalizzate aggiuntive, configurando poi firewall (nas/router) ed instradamento (router) per le sole https.
in DS Video ho la spunta su "usa https" e nell'indirizzo metto il mio FQDN:porta_personalizzata_aggiuntiva_https.
Non ho dispositivi apple e su android (prevalentemente Samsung, ma anche Minix) con DSVideo+MXPlayer non ho mai avuto problemi, ne con certificato autoprodotto (per il quale non li ho mai importati sui dispositivi), ne con certificato firmato da LetsEncrypt.
Dal 01.01.2015 non rispondo a quesiti tecnici dei non osservanti il regolamento http://www.synologyitalia.com/presentazioni/regolamento-leggere-prima-di-postare-t5062.html

  • UPS: APC SMT2200I+AP9631
  • GTW: Vigor2862Vac(3.8.8.2): Multiwan 2xVDSL(200M/30M,1+8IP)+USB4G :o
  • SWC: DLink DGS1210-28P (PoE+)
    • 4x HP NJ2000G
    • 4x HP NJ220
    • 2x Netgear GS108Tv2
    • 2x VigorAP902
  • NAS: DS1815+: DSM6.1(15152u3),16GB; R1(2x845DCPro),R5(3xWD60EFRX),R0(2xWD60PURX),VB(WD60EFRX);LAN:LAG(1+2),3,4 :D
    • RS3617xs+: DSM6.1(15152u3),8GB; R5(8xWD40FFWX),HS(WD40FFWX); LAN:LAG(1+2+3),4,LAG(5+6)
    • RS2414RP+: DSM5.2(5967u1),4GB; R10(4xWD30EFRX),R5(3xWD30EFRX),HS(WD30EFRX); LAN:LAG(1+2+3),4
  • ALTRO: Denon AVR-4311
    • UE55ES8000Q, UE32ES6800Q, UE22F5410AY
    • Galaxy Note8, A5, TabS3; Nokia N8
  • EXP: E4: NET9 PC:W9,M0,L6

Rispondi

Torna a “Video Station”