Negozio Synology prezzi bassi

Installazione WordPress

Usare il NAS come Web Server (Drupal, Joomla, WordPress ...)

Installazione WordPress

Messaggioda Synoale » sabato 2 dicembre 2017, 11:41

Ciao a tutti,
Mi spiace disturbare con un argomento forse già trattato ma...

Sto cercando di installare WordPress 4.7.5 dai pacchetti offerti dal mio nas (DS916+).
Mi dice che devo installare MariaDb 10 prima... ok... parte l'installazione.
Mi chiede una autenticazione di MariaDB 10. ok
Vedo scritto: account: root e poi password.
Bene io metto gli accessi generali del mio NAS; quelli di amministrazione.
Prosegue, installa WP poi si ferma e dice che non si riesce a collegare a MARIA DB 10.
A questo punto sono ripartito da capo, cancellando tutto e ripartendo da zero
Ho provato varie volte, anche lasciando root, cambiando password, ma nulla da fare !
il messaggio è sempre: WP non si collega a MARIA (mai nome fu più funesto)
E quando apro MARIADB 10 con un click, mi offre solo di resettare la password oppure di cancellare il database.
E qualunque cosa faccia non risolvo...
Dove sbaglio? Qualcuno mi può aiutare? Grazie
Utilizzo DSM 6.1.4 - 15217 update 2, l'ultimo sistema operativo ad oggi (dic. 2017)
Synoale
Utente
Utente
 
Messaggi: 3
Iscritto il: sabato 2 dicembre 2017, 11:26

Re: Installazione WordPress

Messaggioda burghy86 » sabato 2 dicembre 2017, 15:52

Fai l'installazione senza pacchetto estraendo tutto nella cartella web . Con php my admin crei il db e l'utente
ATTENZIONE PRIMA DI POSTARE
Passare dalla sezione presentazioni e leggere il regolamento firma obbligatorio

siamo una community, aiutateci a sentirci parte di qualcosa e non un helpdesk
Non do aiuto in privato ma sul forum a tutti!!
Un grazie ci spinge a lavorare meglio

------------------------------------------------------------
  • UPS: apc
  • GTW: netgear dgn2200 o TP-LINK TD-W8970 ISP: [ADSL] intred(20000/1024/0) IP:[pubblico]
  • SWC: hp gigabit 8 porte with poe
  • NAS: ds213, ds213j,ds210j,ds413j, ds215j, ds415+ dmv dal 5.2 alla 6. qnap ts212p ts22, all hd con wdred da 2/6tb
  • CLI: xpsp3, seven pro 64bit, win 8.1 64bit, mac, win 10
    [altro]
  • 3 smartphone android, un iphone5,lettore bd with allshare samsung, vodafone tv, raspberry p2 e p3
Avatar utente
burghy86
Moderatore
Moderatore
 
Messaggi: 8755
Iscritto il: martedì 11 settembre 2012, 18:59

Re: Installazione WordPress

Messaggioda Synoale » lunedì 4 dicembre 2017, 11:10

Grazie mille, ci provo
Alessandro
Synoale
Utente
Utente
 
Messaggi: 3
Iscritto il: sabato 2 dicembre 2017, 11:26

Re: Installazione WordPress

Messaggioda Synoale » lunedì 4 dicembre 2017, 12:00

Ho installato tutto il pacchetto WP libero direttamente nella root della cartella web (facendo sparire il resto)
Ho installato phpmyadmin e creato il db, con un utente amministratore (tutti i privilegi) sul suddetto dabtase
Dopo ho cercato di puntare sulla pagina
http://mionas/wp-admin/install.php
Ma mi compare errore: La pagina non funziona

192.168.0.200 al momento non è in grado di gestire la richiesta.
HTTP ERROR 500

Perché non legge install.php? visto che ho tutto installato (php, apache, mariadb...) ??
Non dovrei partire da lì?
Scusa se rompo ma ero troppo abituato con il pacchetto auto-installante di Synology e ora faccio fatica.
Grazie per l'aiuto...
Alessandro
Synoale
Utente
Utente
 
Messaggi: 3
Iscritto il: sabato 2 dicembre 2017, 11:26

Re: Installazione WordPress

Messaggioda Oldman » martedì 15 maggio 2018, 10:28

io mi ritrovo con lo stesso problema. Ho installa webserver, mariadb10, php 5.6, apache 2.2.
Configurato il web server tutto in verde, ma se apro mariadb mi chiede la pwd che non ho, provo a resettare
e ricreare una nuova utilizzando anche io gli stessi ingressi del nas niente da fare.
Provo ad installare wordpress, parte l'installazione ma dice che non riesce a collegarsi con mariadb.
L'unico dubbio che mi sorge e che tempo fa installai il pacchetto e tutto funziono perfettamente, ora non so se sia
rimasto qualche cosa memorizzato con le pwd (che non riesco a ricordare) sta di fatto che nemmeno myphpadmin si riesce a collegare.
Ho provato sia a cancellare tutti i dati durante l'installazione di wordpress che no, sta di fatto che non riesco ad installare niente.
  • UPS: --------
  • GTW: Tim Smart ISP: Fibra Telecom (100/20) IP: Public
  • SWC: --------
  • NAS: DS916+ DSM [6.1.4-15217 Update 2 Ram;8Gb Storage; 4x4 TB Raid 5 + hot spare (8TB)
  • CLI: I5 2xSSD 500GB 1xHDD 1TB Ram 16Gb window 10 64bit
  • ALTRO: 1x Dell xps13 ssd 1x500Gb ram 16Gb
  • SmartTV LG, Samsung
  • eventuali dispositivi :Samsun S5 - Samsung tablet S2 8''
[*]EXP: E 6 - NET 1 PC:W 1 M 0 L0
[/list]
Oldman
Utente
Utente
 
Messaggi: 64
Iscritto il: sabato 18 marzo 2017, 17:02

Re: Installazione WordPress

Messaggioda dMajo » giovedì 17 maggio 2018, 14:39

phpmyadmin ti chiede le credenziali di mariadb.
per una nuova installazione l'utente è root e la password blank.
configura la psw dopo il primo accesso.
crea un nuovo utente e un nuovo DB per WP
Dal 01.01.2015 non rispondo a quesiti tecnici dei non osservanti il regolamento http://www.synologyitalia.com/presentazioni/regolamento-leggere-prima-di-postare-t5062.html

  • UPS: APC SMT2200I+AP9631
  • GTW: Vigor2830Vn+(3.6.8.6): Multiwan 2xADSL(20M/1M/mcr512K,8IP)+USB4G :o
  • SWC: DLink DGS1210-28P (PoE+)
    • 4x HP NJ2000G
    • 4x HP NJ220
    • 2x Netgear GS108Tv2
    • 2x VigorAP900
  • NAS: DS1815+: DSM6.1(15152u3),16GB; R1(2x845DCPro),R5(3xWD60EFRX),R0(2xWD60PURX),VB(WD60EFRX);LAN:LAG(1+2),3,4 :D
    • RS3617xs+: DSM6.1(15152u3),8GB; R5(8xWD40FFWX),HS(WD40FFWX); LAN:LAG(1+2+3),4,LAG(5+6)
    • RS2414RP+: DSM5.2(5967u1),4GB; R10(4xWD30EFRX),R5(3xWD30EFRX),HS(WD30EFRX); LAN:LAG(1+2+3),4
  • ALTRO: Denon AVR-4311
    • UE55ES8000Q, UE32ES6800Q, UE22F5410AY
    • Galaxy Note8, A5, TabS3; Nokia N8
  • EXP: E4: NET9 PC:W9,M0,L6
Avatar utente
dMajo
Moderatore
Moderatore
 
Messaggi: 1678
Iscritto il: sabato 18 agosto 2012, 23:14
Località: FVG - Italia


Torna a Web Server (Web Station)

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti