Negozio Synology prezzi bassi

Mail Station: Errore SMTP 501

Gestire la posta elettronica sul NAS, sincronizzazione di agenda e contatti

Re: Mail Station: Errore SMTP 501

Messaggioda ginopilotino » lunedì 31 ottobre 2016, 13:01

Voglio cmq andare a fondo della faccenda, sto cercando di capire quale possa essere il problema con l'autenticazione e a cosa è legato. E' un po' un casino perche' sono abituato a debian, dove tutta la roba e' li dove deve stare, synology e' un po' pasticciona :mrgreen:
  • UPS: APC CS650
  • GTW: Netgear DGN2200v3 ISP: ADSL Alice (7M) IP:Public
  • SWC: Vari
  • NAS: 1515+ DSM 6.0(7321); Ram 16GB; Storage SHR(3x4TB RED + 2x4TB Seagate VX); LAN:4
  • CLI: Windows 7
  • WD Live HD - Vodafone TV Solution
  • EXP: E4 - NET10 PC:W10,M7,L8
ginopilotino
Utente
Utente
 
Messaggi: 52
Iscritto il: venerdì 29 gennaio 2010, 21:31

Re: Mail Station: Errore SMTP 501

Messaggioda ginopilotino » lunedì 31 ottobre 2016, 13:54

Collegandomi all'smtp di tiscali e lanciando un ehlo, ottengo:

ehlo prova
250-santino.mail.tiscali.it hello [80.181.100.183], pleased to meet you
250-AUTH LOGIN PLAIN CRAM-MD5 DIGEST-MD5
250-SIZE 34865152
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 OK

Quindi mi sembra tutto ok.
Provando l'autenticazione:

220 santino.mail.tiscali.it ESMTP service ready
auth login
334 VXNlcm5hbWU6
xxxxxxxxxxxx
334 UGFzc3dvcmQ6
xxxxxxxxxxxxx
235 2.7.0 LOGIN authentication successful

Quindi in modalita' login e' ok (ho encodato user e password in Base64)
  • UPS: APC CS650
  • GTW: Netgear DGN2200v3 ISP: ADSL Alice (7M) IP:Public
  • SWC: Vari
  • NAS: 1515+ DSM 6.0(7321); Ram 16GB; Storage SHR(3x4TB RED + 2x4TB Seagate VX); LAN:4
  • CLI: Windows 7
  • WD Live HD - Vodafone TV Solution
  • EXP: E4 - NET10 PC:W10,M7,L8
ginopilotino
Utente
Utente
 
Messaggi: 52
Iscritto il: venerdì 29 gennaio 2010, 21:31

Re: Mail Station: Errore SMTP 501

Messaggioda ginopilotino » lunedì 31 ottobre 2016, 16:15

Chi l'ha dura la vince!

Allora, prima di tutto ho abilitato il debuging nel file di configurazione config.inc.php che si trova in /volume1/@appstore/MailStation/mail/config.

Dopo di che ho capito che il problema era la stringa che passava al comando HELO, che era vuota. Allora, sempre nel file di config, gli ho forzato la stringa "prova".
Ripartito tutto, roundcube mi dava errore 535 di autenticazione.
Riguardando il log, ho capito che usava un'autenticazione diversa dal tipo "LOGIN", ho forzato nel file di configurazione questa modalita' ed ora va una crema :mrgreen:
  • UPS: APC CS650
  • GTW: Netgear DGN2200v3 ISP: ADSL Alice (7M) IP:Public
  • SWC: Vari
  • NAS: 1515+ DSM 6.0(7321); Ram 16GB; Storage SHR(3x4TB RED + 2x4TB Seagate VX); LAN:4
  • CLI: Windows 7
  • WD Live HD - Vodafone TV Solution
  • EXP: E4 - NET10 PC:W10,M7,L8
ginopilotino
Utente
Utente
 
Messaggi: 52
Iscritto il: venerdì 29 gennaio 2010, 21:31

Re: Mail Station: Errore SMTP 501

Messaggioda ginopilotino » lunedì 31 ottobre 2016, 16:24

MassiDiFi ha scritto:Mi dispiace non esserti di maggior aiuto!

:(


Credo proprio che il tuo problema fosse identico, quell'errore salta fuori proprio quando invia il comando HELO, evidentemente con l'ultimo aggiornamento hanno scazzato qualcosa e manda una stringa vuota. Bisogna forzarlo nel file di configurazione. Mentre per il metodo di login, ho paura che vada a prendere l'ultimo indicato dal comando EHLO, solo che magari non è neanche in grado di autenticarsi a quel modo, come nel mio caso.
  • UPS: APC CS650
  • GTW: Netgear DGN2200v3 ISP: ADSL Alice (7M) IP:Public
  • SWC: Vari
  • NAS: 1515+ DSM 6.0(7321); Ram 16GB; Storage SHR(3x4TB RED + 2x4TB Seagate VX); LAN:4
  • CLI: Windows 7
  • WD Live HD - Vodafone TV Solution
  • EXP: E4 - NET10 PC:W10,M7,L8
ginopilotino
Utente
Utente
 
Messaggi: 52
Iscritto il: venerdì 29 gennaio 2010, 21:31

Re: Mail Station: Errore SMTP 501

Messaggioda MassiDiFi » lunedì 31 ottobre 2016, 17:05

ginopilotino ha scritto:
MassiDiFi ha scritto:Mi dispiace non esserti di maggior aiuto!

:(


Credo proprio che il tuo problema fosse identico, quell'errore salta fuori proprio quando invia il comando HELO, evidentemente con l'ultimo aggiornamento hanno scazzato qualcosa e manda una stringa vuota. Bisogna forzarlo nel file di configurazione. Mentre per il metodo di login, ho paura che vada a prendere l'ultimo indicato dal comando EHLO, solo che magari non è neanche in grado di autenticarsi a quel modo, come nel mio caso.


Quindi?!

:D :D :D :D
Ups: APC
Nas: DS211
SWC: Netgear 8 Porte Gigabit
MassiDiFi
Utente
Utente
 
Messaggi: 30
Iscritto il: lunedì 21 marzo 2011, 19:17

Re: Mail Station: Errore SMTP 501

Messaggioda ginopilotino » lunedì 31 ottobre 2016, 17:53

MassiDiFi ha scritto:
ginopilotino ha scritto:
MassiDiFi ha scritto:Mi dispiace non esserti di maggior aiuto!

:(


Credo proprio che il tuo problema fosse identico, quell'errore salta fuori proprio quando invia il comando HELO, evidentemente con l'ultimo aggiornamento hanno scazzato qualcosa e manda una stringa vuota. Bisogna forzarlo nel file di configurazione. Mentre per il metodo di login, ho paura che vada a prendere l'ultimo indicato dal comando EHLO, solo che magari non è neanche in grado di autenticarsi a quel modo, come nel mio caso.


Quindi?!

:D :D :D :D


Quindi se vuoi risolvere quel problema, e' meno complicato di quanto sembra.
Anzitutto installi sul nas il pacchetto "config file editor" della community. Da li vai su "choose config file" scegli l'ultima opzione "config file editor". Li dentro alla fine aggiungi:

/volume1/@appstore/MailStation/mail/config/config.inc.php,config.inc.php

Quindi salvi e di nuovo da "choose config file" sta volta scegli "config.inc.php". Si apre il file di config e vai a modificare nella sezione "// SMTP" questo:

$config['smtp_helo_host'] = 'prova';

Se e' come nel mio caso, riavviando mailstation e mailserver, dovresti ottenere un errore diverso. Probabilmente a te bastera' questo. Altrimenti va cambiata anche la voce:

$config['smtp_auth_type'] = 'LOGIN';
  • UPS: APC CS650
  • GTW: Netgear DGN2200v3 ISP: ADSL Alice (7M) IP:Public
  • SWC: Vari
  • NAS: 1515+ DSM 6.0(7321); Ram 16GB; Storage SHR(3x4TB RED + 2x4TB Seagate VX); LAN:4
  • CLI: Windows 7
  • WD Live HD - Vodafone TV Solution
  • EXP: E4 - NET10 PC:W10,M7,L8
ginopilotino
Utente
Utente
 
Messaggi: 52
Iscritto il: venerdì 29 gennaio 2010, 21:31

Re: Mail Station: Errore SMTP 501

Messaggioda MassiDiFi » lunedì 31 ottobre 2016, 18:13

Perfetto!
Mercoledì mattina appena entro in studio provo!
Ti tengo aggiornato!
Ups: APC
Nas: DS211
SWC: Netgear 8 Porte Gigabit
MassiDiFi
Utente
Utente
 
Messaggi: 30
Iscritto il: lunedì 21 marzo 2011, 19:17

Re: Mail Station: Errore SMTP 501

Messaggioda MassiDiFi » mercoledì 2 novembre 2016, 11:15

Ciao

Ho installato Config file editor e ho modificato config file editor inserendo alla fine del file:

/volume1/@appstore/MailStation/mail/config/config.inc.php,config.inc.php

Ora devo modificare config.inc.php ma non ho capito come devo modificarlo

Questo è la parte inerendte all SMTP

Devo semplicemente inserire la parola prova tra le virgolette?

Codice: Seleziona tutto
// ----------------------------------
// SMTP
// ----------------------------------

// SMTP server host (for sending mails).
// To use SSL/TLS connection, enter hostname with prefix ssl:// or tls://
// If left blank, the PHP mail() function is used
// Supported replacement variables:
// %h - user's IMAP hostname
// %n - hostname ($_SERVER['SERVER_NAME'])
// %t - hostname without the first part
// %d - domain (http hostname $_SERVER['HTTP_HOST'] without the first part)
// %z - IMAP domain (IMAP hostname without the first part)
// For example %n = mail.domain.tld, %t = domain.tld

// SMTP port (default is 25; use 587 for STARTTLS or 465 for the
// deprecated SSL over SMTP (aka SMTPS))

// SMTP username (if required) if you use %u as the username Roundcube
// will use the current username for login
$config['smtp_user'] = '%u';

// SMTP password (if required) if you use %p as the password Roundcube
// will use the current user's password for login
$config['smtp_pass'] = '%p';

// SMTP AUTH type (DIGEST-MD5, CRAM-MD5, LOGIN, PLAIN or empty to use
// best server supported one)
$config['smtp_auth_type'] = '';

// Optional SMTP authentication identifier to be used as authorization proxy
$config['smtp_auth_cid'] = null;

// Optional SMTP authentication password to be used for smtp_auth_cid
$config['smtp_auth_pw'] = null;

// SMTP HELO host
// Hostname to give to the remote server for SMTP 'HELO' or 'EHLO' messages
// Leave this blank and you will get the server variable 'server_name' or
// localhost if that isn't defined.
$config['smtp_helo_host'] = '';

// SMTP connection timeout, in seconds. Default: 0 (use default_socket_timeout)
// Note: There's a known issue where using ssl connection with
// timeout > 0 causes connection errors (https://bugs.php.net/bug.php?id=54511)
$config['smtp_timeout'] = 0;

// SMTP socket context options
// See http://php.net/manual/en/context.ssl.php
// The example below enables server certificate validation, and
// requires 'smtp_timeout' to be non zero.
// $config['smtp_conn_options'] = array(
//   'ssl'         => array(
//     'verify_peer'     => true,
//     'verify_depth     => 3,
//     'cafile'          => '/etc/openssl/certs/ca.crt',
//   ),
// );
$config['smtp_conn_options'] = null;
Ups: APC
Nas: DS211
SWC: Netgear 8 Porte Gigabit
MassiDiFi
Utente
Utente
 
Messaggi: 30
Iscritto il: lunedì 21 marzo 2011, 19:17

Re: Mail Station: Errore SMTP 501

Messaggioda ginopilotino » giovedì 3 novembre 2016, 22:28

Cerca le righe che ti ho indicato e sostituiscile a quelle esistenti. Hai le stesse voci ma con '' invece di '<valore>'
  • UPS: APC CS650
  • GTW: Netgear DGN2200v3 ISP: ADSL Alice (7M) IP:Public
  • SWC: Vari
  • NAS: 1515+ DSM 6.0(7321); Ram 16GB; Storage SHR(3x4TB RED + 2x4TB Seagate VX); LAN:4
  • CLI: Windows 7
  • WD Live HD - Vodafone TV Solution
  • EXP: E4 - NET10 PC:W10,M7,L8
ginopilotino
Utente
Utente
 
Messaggi: 52
Iscritto il: venerdì 29 gennaio 2010, 21:31

Precedente

Torna a Mail Server, Mail Station & Cal/CardDAV

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite